In this lesson you will learn how to:
 Add a border and shadow to the title.
 Add a block of freeform text.

Tutorials

 Customize freeform text.
 Display dates with symbols.

 Annotate a symbol using symbol text.

Lesson 3 – Work with Text

 Add text in the middle of a bar using symbol text.
 Add angled text.
 Adjust symbol and date text position.
 Add symbol notes.

Open the schedule for this lesson
1. On the toolbar choose the File tab.
2. In the Files and Templates: Open and Save Options section, click (the
down arrow) next to Open.
3. Choose Lesson Chart.
4. Select Lesson 3 Starter Schedule.mlf.
5. Save the schedule to an folder on your computer, such as your Documents folder. Choose File tab, in the Files and Templates: Open and
Save Options section. Click  (the down arrow) next to Save As ... and
choose Chart. You will now be able to work with and save this schedule.
Lesson 3 starter schedule

Add a border and shadow to the title
1. Click

in the toolbox.

2. Click the title Roof Project. The toolbar will change to the Selection tab with Current Object: Chart Title. It now displays
all the chart title’s properties. The image of the toolbar below shows the title properties to change.

Numbers 1-9 above refer to these numbered instructions:
Roof Project

1. For title text justification, choose the center icon.
2. Under Text Highlights choose Shadow.
3. In the Background Color section click the top rectangle to open
the color palette. Choose teal (or another color of your choice).
4. In the Background Color section, for Special Effects choose Fade
to Right.
5. In the Background Color section, for Target Color click the rectangle to open the color palette. Choose light blue (or another color
of your choice).

6. In the Border and Shadow section, Border Type choose Width of
Schedule.
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7. In the Border and Shadow section, Shadow choose Small.
8. In the Border and Shadow section, Shadow click the rectangle to
open the color palette. Choose brown (or another color of your choice).

Enhanced title

9. To have the changes applied to your schedule in the Tile Text Settings section choose the
change made above button.
3-1

Press here to apply text

Add a block of freeform text
1. Click

in the toolbox.

Roof Project

2. Click in the schedule area, to the right of the Nail on shingles step.
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3. Type "3-Man crew to arrive".
4. Press Enter to split the text onto a new line.

Nail on shingles

5. Type "by 8am daily.".

3-Man crew to arrive
by 8am daily.

Freeform text

Customize freeform text
1. Click

in the toolbox.

2. Click the freeform text 3-Man crew to arrive by 8am daily. The toolbar will change to the Selection tab with Current
Object: Freeform Text and display the freeform text properties.

5

Numbers 1-11 above refer to these numbered instructions:
1. In the Font section change the font to Arial.

2. Change the Size to 24.
3. For Horizontal Alignment, choose the center icon.
4. For Text Style click the Bold, Italic and Underline icons.
5. Click the Text Color rectangle to open the color palette. Choose teal.
6. In the Background Color/Border section click on the Set Fill Color rectangle to open the color palette. Choose gold.
7. Change the Special Effects to Fade to Bottom.
8. Click on the Target Color rectangle to open the color palette. Choose light yellow.
9.

 Transparent (Disables Background Color).

10.  Show Shadow.
11. Click on the Set Shadow Color rectangle to open the color palette. Choose gold.

Enhanced freeform text



Freeform text placement can be adjusted by using the arrow tool in the toolbox.



Change freeform text properties easily. First click the arrow tool in the toolbox.
Click once on the text. The toolbar containing all of the freeform text properties
will be shown.
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Display dates with symbols

Roof Project

1. In the toolbox, double-click the
symbol that is used for the start
symbols on your schedule. The Symbol Options dialog box displays.
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2. Click the Text and Date Properties tab.
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3. Under Date Placement, choose Above and Center.
8/2

4. Click OK. Each start symbol now has a date displayed above it.
To change the format of the dates shown: choose the Dates tab. In the
Date Related Settings section, click Set Symbol Date Format. Choose
from a list of predefined formats (or create a custom format.)

Tear off old roof

Put down tar paper

3-Man crew to arrive
by 8am daily.

Nail on shingles

8/9

Dates displayed with symbols

Annotate a symbol with symbol text
1. Click

in the toolbox.

2. Click the end symbol for the Get materials step. The toolbar will change to display all of the symbol's properties. The
image of the toolbar below shows the symbol properties to change.

Numbers 1-7 above refer to these numbered instructions:
1. In the Text section for Line 1 type in Materials.

2. In the Text section click Text Overrides for Line 1. The Symbol Text
Line 1 Overrides dialog box will come up. Under Text Color Override
click the Press to Change Color rectangle to open the color palette.
Choose light brown. Click OK.
3. In the Text section for Line 2 type in Tar paper, shingles, nails.
4. In the Text section for Suffix, type in Est.
5. In the Text Placement section for Horizontal choose
Right.

Roof Project
Project Steps

6. In the Date Placement section for Vertical choose
Above.
7. Press

the Apply Text Changes button.

Just the month and day are displayed for symbol dates in this example. If you would like
something different, choose the Dates tab. In
the Date Related Settings section, click Set
Symbol Date Format and choose from a list of
predefined formats or create a custom format.
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3-Man crew to arrive
by 8am daily.

Text added to a symbol

3-3
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Add text in the middle of a bar using symbol text
1. Click

in the toolbox.

2. Click the start symbol for Tear off old roof. The toolbar will change to display all the symbol properties. The image of the
toolbar below shows the symbol properties to change.

Roof Project

Numbers 1-5 above refer to these numbered instructions:
1. In the Text section for Line 1 type in Smith Const.

Aug'17

Project Steps

2. In the Text section click Text Overrides for Line 1. The Symbol Text Line 1 Overrides dialog box will come up. Under
Text Color Override click the Press to Change Color rectangle to open the color palette. Choose light gold. Click OK.
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Smith Const.

3. In the Text Placement section for Vertical choose Middle.
4. In the Text Placement section  Center Text on Bar.
5. Press

Put down tar paper

(the Apply Text Changes button.)
3-Man crew to arrive
by 8am daily.

Nail on shingles

Always use the left-most symbol to enter text for a bar.

8/9

Text in the middle of a bar

Draw symbol text at an angle
1. Click

in the toolbox.

2. Click the milestone for Put down tar paper. The toolbar will change to the Selection tab and display all the symbol properties. The image of the toolbar below shows the symbol properties to change. Numbers 1-7 are described below. .

Numbers 1-7 above refer to these numbered instructions:
1. In the Text section for Line 1 type in RAIN SCHEDULE.
2. In the Font section select the Color rectangle to open the color
palette. Choose teal.

Roof Project
Project Steps

3. In the Font section choose B to bold the text.
4. In the Font section choose  (the down arrow) to select Size 18.
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5. In the Text Placement section for Vertical choose Above.
Tear off old roof
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6. In the Text Placement section  Draw Text at Angle.

Put down tar paper

Nail on shingles

3-Man crew to arrive
by 8am daily.
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Angled text


Angled text will only show a single line of text regardless of how many lines of text are entered.



The default angle is set to 45 degrees. To change the angle click the Tools tab in the Program Options section choose Edit. Under Angle for Angled Symbol Text click (the down arrow) and choose the degree.

3-4

For future reference: tips for adjusting the position of symbol text
Vertically move symbol text
1. Select the symbol and the vertical line type to be used for vertical symbol text move. Choose the Tools tab. In the Customize section choose Symbol Text Move.
2. Using the scroll arrows choose a Symbol from the list that you are not currently using on your schedule. The symbol will
then become an invisible symbol in the toolbox.
3. Using the scroll arrows choose a Vertical link.
4. Click

in the toolbox.

5. On the schedule, click once on the symbol with the text.
6. Hold down Ctrl + T.
7. Click and drag to move the invisible symbol and its text to another task row.

Adjust symbol text position with the keyboard:
1. Click

in the toolbox.

2. On the schedule, click once on the symbol with the text to be moved.
3. Hold down the ALT key.
4. Click the arrow keys on the keyboard to move the text around the symbol. The text will move as you click the arrow keys.

Adjust symbol date position with the keyboard:
1. Click

in the toolbox.

2. On the schedule, click once on the symbol with the symbol date to be moved.

3. Hold down ALT + CTRL.
4. Click the arrow keys on the keyboard to move the symbol date around the symbol. The symbol date will move as you
click the arrow keys.

3-5

Symbol Notes
Next, you will add a symbol note with formatted text and a picture.
Add a picture to the schedule and give it a tag of “wm”
1. On the Insert tab, in the Picture, Legend section, choose Picture from File and add any picture you might have on your
computer. When
(the picture cursor appears), click somewhere on the schedule to add the picture.

2. With (the arrow tool), click the picture which is now on the schedule.
3. For Automation Tag, enter wm and press

(the Apply Settings button.)

Add symbol notes to a symbol
1. Click

in the toolbox.

2. Click
(the end symbol for Tear off old roof.) On the Selection tab, choose the small Notes tab. The toolbar now displays symbol note properties.

Numbers 1-12 above refer to these numbered instructions:
1.  Display Note on Schedule.
2.

In the note text box type in Dumpster removal by Waste Management

3.

Press Enter on the keyboard and type in the following markup code to
have the picture show in the notes on the schedule. <image tag=“wm”>
(The wm in the tag refers to the picture which was “tagged” with wm in
an earlier step.)

4.

Press Enter and type in Friday 8/9/2013. Then type in the following:
Friday 8/9/2013. <i><b><rgb:255,0,0> (Anything inside <> is a “markup
code” <i> for Italic, <b> for bold, and <rgb:255,0,0> for red. (See the
image above with #3 which illustrates all that should be entered)

Symbol note

5.

Choose to center all the text.

6.

Set the font size to 11.

7.

Press

8.

Select a Background Color by clicking on the colored box and selecting from the color palette.

9.

Select a Target Color by clicking on the colored box and selecting from the color palette.

(the Apply Text Changes button.)

10. Select a Frame Color by clicking on the colored box and selecting from the color palette.
11. Choose the special effect Fade to Edge.
12. Choose a Connector Type and Color. The connector draws a link between the notes box and the symbol.
13. Use the direction controls to move the symbol note (or click and drag with the mouse.)
 Images need to be in the Milestones file to appear in a note. The image needs to be placed somewhere on the schedule and
“tagged”. (If the picture is not displayed on the schedule then place and tag the image on a unused page.) The Manage Pictures option on the Tools menu makes it easy to find and move pictures from page to page. Moving a picture to a page does
not add a page to the file.

 The image command needs to be on a line by itself, as anything else on the line is ignored.
 The image is displayed using its existing size on the schedule. Simply drag the corner of the picture and the picture will resize as
well as the picture in the note.

 You must use hard line breaks to control the line breaks in the displayed note as text is not word wrapped. A line is limited to
no more than 150 characters
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The schedule should look similar to this one (with a different graphic of your choice):

Roof Project
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Symbol note, text and picture

More About Milestones Professional and Text.


Symbol Text or Symbol Notes are the best way to annotate large schedules, especially if the text needs to "stick" to
a task or symbol.



Default Symbol Text is applied to symbols by double clicking a symbol in the toolbox and choosing the Symbol Options dialog box, Default Text tab. Each time the symbol is added to the schedule, the default text will also be added. Text attached to any symbol already on the schedule will not be affected by changes to the Default Text. That is,
changes to the Default Text only affect symbols that are subsequently added not those already on the schedule.



Freeform Text is most useful for blocks of text that are independent of any task or symbol. Freeform text will not
move with a task row -- it is placed relative to the page. Ideal uses for freeform text are headers and footers.



To have text stick to a task without displaying a symbol, consider using a comment symbol. A comment symbol can
be a blank symbol or a very small symbol on a task row. The comment symbol is ignored when computing start date,
end date and duration so it can be placed anywhere on the schedule. To create a comment symbol, just double-click
any unused symbol in the toolbox and choose Comment Symbol under the Symbol Shape tab.



To change the Default Symbol Text style and size first choose the Format tab. In the Default Text section, click Symbol Text and make changes.
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